Unable to log in to the platform
Incident Report for Blackfynn
Resolved
The incident has been resolved.
Posted May 27, 2020 - 11:23 EDT
Investigating
We are investigating this issue.
Posted May 27, 2020 - 11:10 EDT
This incident affected: Core (Data Modeling, File Management, Collaboration).